[shadow-support] Need help on shadow installation problems

Timothy Kale kale.timothy at gmail.com
Wed May 22 02:32:04 CDT 2013


Hi Rob,

Thanks for your reply. However, I tried the command you gave me earlier
about hundred times for both Ubuntu 12.04 LTS and Ubuntu 11.10. The same
error still occurs. This is for Shadow 1.7.0. release.
I tried to figure out where I gone wrong in my setup, check all my
configurations but still I cannot figure out why I always end up having the
errors below.
Please I need instructions on how do you set up yours. The instructions
here didn't work out for me:
https://github.com/shadow/shadow/wiki/Preparing-your-machine#building-and-installing-shadow-and-its-plug-ins



CMake Error at src/hoist/CMakeLists.txt:6 (find_package):
By not providing "FindLLVM.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "LLVM", but
CMake did not find one.

Could not find a package configuration file provided by "LLVM" with any of
the following names:

LLVMConfig.cmake
llvm-config.cmake

Add the installation prefix of "LLVM" to CMAKE_PREFIX_PATH or set
"LLVM_DIR" to a directory containing one of the above files. If "LLVM"
provides a separate development package or SDK, be sure it has been
installed.


-- Configuring incomplete, errors occurred!
[2013-05-21 21:03:30.834798] Shadow Setup: cmake returned 1
[2013-05-21 21:03:30.834968] Shadow Setup: ERROR! Non-zero return code from
cmake.
[2013-05-21 21:03:30.835077] Shadow Setup: returning code '1'


Best regards,

Timothy



On Wed, May 22, 2013 at 8:00 AM, Rob Jansen <jansen at cs.umn.edu> wrote:

> Please try the following and let me know if it works:
>
> $ ./setup build --include ~/.local/share/llvm/cmake
>
> This has been fixed in master:
>
> https://github.com/shadow/shadow/commit/db1fd85d99e73837a1d9fc0c6abcf34af944a53c
>
> Rob
>
>
> On Tue, May 21, 2013 at 8:09 AM, Timothy Kale <kale.timothy at gmail.com>wrote:
>
>> Hi Rob,
>>
>> Recently I tried to install shadow Shadow v1.7.0<https://github.com/shadow/shadow/archive/v1.7.0.tar.gz>into my single linux box (Ubuntu 12.04.2 LTS) and I end up having this
>> error message below. I followed all the instructions in the "
>> https://github.com/shadow/shadow/wiki/Preparing-your-machine#building-and-installing-shadow-and-its-plug-ins" but still that problem occurs. Please can you help me solve this problem
>> so that I can begin with my simulation experiments? Your responds is highly
>> appreciated, thanks. Best Regards,
>>
>>
>> CMake Error at src/hoist/CMakeLists.txt:6 (find_package):
>>   By not providing "FindLLVM.cmake" in CMAKE_MODULE_PATH this project has
>>   asked CMake to find a package configuration file provided by "LLVM", but
>>   CMake did not find one.
>>
>>   Could not find a package configuration file provided by "LLVM" with any
>> of
>>   the following names:
>>
>>     LLVMConfig.cmake
>>     llvm-config.cmake
>>
>>   Add the installation prefix of "LLVM" to CMAKE_PREFIX_PATH or set
>>   "LLVM_DIR" to a directory containing one of the above files.  If "LLVM"
>>   provides a separate development package or SDK, be sure it has been
>>   installed.
>>
>>
>> -- Configuring incomplete, errors occurred!
>> [2013-05-21 21:03:30.834798] Shadow Setup: cmake returned 1
>> [2013-05-21 21:03:30.834968] Shadow Setup: ERROR! Non-zero return code
>> from cmake.
>> [2013-05-21 21:03:30.835077] Shadow Setup: returning code '1'
>> timexp at timexp:~/shadow-1.7.0$
>>
>>
>>
>>
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.cs.umn.edu/archives/shadow-support/attachments/20130522/00844a0c/attachment.html>


More information about the shadow-support mailing list