[shadow-support] Shadow pthread_cond_init Invalid Argument

Rob Jansen rob.g.jansen at nrl.navy.mil
Sun Feb 7 14:44:03 CST 2016


> On Feb 6, 2016, at 5:46 PM, Kevin Ly <kly04 at calpoly.edu> wrote:
> 
> Hello,
> 
> My name is Kevin, and I'm trying to get Shadow to run on my Ubuntu machine, but I'm having an issue. I managed to get Shadow built and installed to completion, but when I try to run it, either by your example
> 
> shadow shadow.config.xml or even by shadow --help, I get an error that reads
> 
> GLib (gthread-posix.c): Unexpected error from C library during 'pthread_cond_init': Invalid argument. Aborting.
> 
> I am running Ubuntu 14.04, Shadow version v1.11.1-2-g40d5c58. My Glib version is v2.40.2 and IGraph v0.6.5
> 
> Is there a fix for this?
> 
> Thank you,
>  - Kevin
> _______________________________________________
> shadow-support mailing list
> shadow-support at cs.umn.edu
> https://wwws.cs.umn.edu/mm-cs/listinfo/shadow-support

This is a known bug. Please see the bug report here:
https://github.com/shadow/shadow/issues/302

I think you need to upgrade your glib. Please add a message to the ticket if upgrading glib works for you; ultimately we need to request the glib maintainer to upgrade the official glib package in Ubuntu to a newer version to make this easier for everyone.

Cheers,
Rob


More information about the shadow-support mailing list